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Printing multiple files from disk
There are two ways to print multiple files from disk:

1. Go through the Print file from disk choice on the File menu, and Shift- or 
Control-click to select several files.

2. Drag the selected files onto the GreenPrint icon or into the GreenPrint 
main window. You can use Windows File Manager (Win 3.1/95) or Explorer 
(Win 95) to help you group the files you wish to print: for example, by date or
by file type.
Use Explorer or File Manager from the File menu to run one of these 
programs if one is not already running.

TIP Press Ctrl+W to move the GreenPrint main window to the top left-hand 
corner of the screen, and free as much space as possible for Explorer or File 
Manager. See the list of keyboard shortcuts for other GreenPrint functions 
you can access from the keyboard.

By default, GreenPrint will format the selected files so that each file begins 
on a new virtual page. The Advanced Print Settings dialog box allows you to 
choose to begin each file on a new physical page.

GreenPrint32 version 1.2 supports Windows 32 multithreading. This means 
that as soon as a print job begins, control returns to the main window, 
allowing you to initiate other print jobs. Each print job generates a status 
window containing a progress indicator. Queued print jobs will always print in
the order in which they were initiated, and will not interrupt jobs that are 
currently printing.





 Printing from a disk file

To print from a file on disk, you can go through the File-Print from disk 
menu option or drag files onto the GreenPrint icon or into the program's 
window once it is running.

The file open dialog looks like this:

It works like any other Windows 95 Explorer-style file open dialog. You can 
Shift- or Control-click to select several files. Once you have made your choice
by double-clicking on a filename or clicking the Open button, the next stage 
of the printing process is the Preprint dialog box. You can use the predefined 
filters to help you select files.

Note: The illustration shows GreenPrint running under Windows 95. The 16-
bit version of GreenPrint uses the Windows 3.1 file common dialogs, which 
also support Shift- and Control-clicking, but not the use of Ctrl-A to select all 
files.





Printing from the Windows clipboard
GreenPrint can print text in the Windows clipboard that originates from any 
Windows application. To access this feature, choose Print from clipboard 
from the File menu. If the clipboard is empty or does not contain text, 
GreenPrint will indicate this, and will not print. If there is valid text in the 
clipboard, this option will bring up the same print settings dialog box as you 
see on printing a file from disk, and you continue exactly as if you were 
printing a disk file. You can edit the text (use the Edit next button in the 
print settings dialog box) and save changes before printing.





 
Uninstalling GreenPrint, or installing a later

version
To uninstall GreenPrint32 under Windows 95, follow these steps:

Enter Control Panel, and double-click Add/Remove Programs

You should see GreenPrint32 listed. Double-click on its entry and all its files 
will automatically be removed from your system.

To install a later version of GreenPrint32 over your existing files, you can do 
one of the following: 
(1) rerun the setup program provided with the newer version of GreenPrint32

(2) copy the newer gprint32.exe and gprint32.hlp files over your existing 
files yourself. The default path for the GreenPrint32 files is 
c:\Program Files\GreenPrint32\

Note that the 16-bit GreenPrint files are named gprint16.exe and 
gprint16.hlp.





Printing options
Basic printing options are set through the Print Settings dialog box.

In addition to the options on this screen, you can press the Advanced print 
options buttons to set options such as margins, lines and columns per virtual 
page and expansion of tabs.

To choose a different typeface (or font) for your output, select 
Choose typeface from the Options menu, press F9 from the main screen, 
or press the button displaying the current typeface in the Print Settings 
dialog box. You can save your typeface preferences to make them the 
default: for example, if you prefer the traditional Courier New.

You can press the Edit button to view or edit your selected files with 
Windows notepad or, with GreenPrint32, the program associated with files 
with the given extension.

When you have finished setting print options, press OK to proceed to select 
a printer and print the selected file(s).

Choose Minimize on use to have the GreenPrint main window automatically
minimize when a print run is complete.

Pressing Cancel at this point or closing the dialog box will cancel printing. 
The dialog box will disappear and GreenPrint will discard any changes to 
print options that you may have made.

If you have hit OK and still want to cancel printing, you can abort the print 
process during spooling. However, your printer may continue to print for 



some time until it exhausts its buffer.

It is possible to edit the filters that GreenPrint uses to display files when 
printing from disk. To do this, choose Modify file open filters from the 
Options menu. The filter that appears at the top of the listbox will be the 
default filter. Choose Save current options from the Options menu to save
this options to disk for future sessions. Note that it is impossible to save 
changes to filters to disk with an unregistered copy of GreenPrint.



  Advanced print options
Advanced printing options include the number of lines and columns per 
virtual page, the number of spaces per tab stop, and margins and padding. 
(Padding refers to the gap between a page border and page text.)

Using the Recalculate, Lines++ and Lines-- buttons, you can alter the 
formatting options and immediately see the effect this will have on the 
number of physical and virtual pages.

For example, if you noticed that your selected file was going to amount to 
13.1 physical pages, hitting the Lines++ button a few times might ensure 
that it printed on 13, rather than 14, pages.

TIP Note that when you use GreenPrint to print several files, each file begins
on a new virtual page. This means that a small change in the number of lines
per page can sometimes cause a significant change in the number of virtual 
and/or physical pages. There is also an option in the Advanced Print Settings 
dialog box to begin new files with a hard (physical) page break.





Saving and loading preferences
Each time you run GreenPrint, it loads the preferences saved in the registry 
or the win.ini file (depending on whether it's the 32 or 16-bit version). 
Initially, it uses the default preferences. However, each time you change a 
print setting, such as the number of virtual pages per physical page or 
margin settings, GreenPrint remembers that change for the remainder of 
your session or until you alter the relevant settings again. If you want your 
new settings to become the settings that are automatically loaded when 
GreenPrint starts, choose Save current options from the Options menu, or 
type Ctrl+S.

If while running GreenPrint you have altered print settings unintentionally, 
you can choose Return to saved options from the Options menu to return to 
the most recently saved options.

You can return to the original default settings at any time by Return to 
default settings from the options menu. If you then choose Save current 
options, the default settings will again be loaded automatically when 
GreenPrint starts.





Keyboard shortcuts

F1 Help contents

F7 Exit

F9 Select typeface

Ctrl+B Toggle border printing

Ctrl+E Run Windows 95 Explorer (to allow file dragging into 
GreenPrint).

Ctrl+F Run legacy File Manager. Note that you can't drag and drop 
from File Manager onto the icon of a Windows32 program such as 
GreenPrint32. However, File Manager is still arguably more powerful than 
Explorer.

Ctrl+L Toggle landscape printing

Ctrl+N Toggle line numbering

Ctrl+O Print file from disk

Ctrl+P " " "

Ctrl+Alt+P Bring up print settings dialog box

Ctrl+S Save current print options to disk

Ctrl+V Print from Windows clipboard

Ctrl+W Toggle the GreenPrint main window to/from the top left corner of 
the screen. (Useful in printing from the clipboard, or printing with drag and 
drop from a program such as Windows 95 Explorer).

Ctrl+1 1 up

Ctrl+2 2 up

Ctrl+4 4 up

Ctrl+8 8 up



Mouse shortcuts

Double-clicking in the main window
Print from disk

Right-clicking in the main window
Print options



About the main-window graphic

The grid in the main-window graphic indicates the current number of virtual 
pages per physical page. If the lines are dashed, GreenPrint is not configured
to print borders. A solid line below the grid indicates that caption printing is 
enabled. The orientation of the graphic (portrait or landscape) indicates the 
current default orientation. Small numbers in the top left virtual page 
indicate that line numbering is switched on, and, if so, the number of lines 
per virtual page. An X in the right-hand corner of the top left virtual page 
indicates that GreenPrint is configured to truncate long lines.

To change these options, use the Print Options dialog box.



Information about GreenPrint development

GreenPrint for Windows was written for the Windows 16 and 32 APIs by 
Rod Johnson. 
rjohnson@extro.ucc.su.oz.au
http://www.usyd.edu.au/~rjohnson/frontpage.html
© June 1996-January 1997.
Versions up to 1.01 were written in ANSI C. Version 1.1 marked a shift to C+
+, and an object-oriented design.

Thanks to Bob West, and those registered users who have made helpful 
suggestions.

Compiles

Both the Windows 95/NT version (gprint32) and the Windows 3.1 version 
(gprint16) were compiled with Watcom C/C++ v. 10.6 on a Pentium running 
Windows 95.

The 16-bit version will continue to be supported in the foreseeable future, 
although it may not include all the features available in the 32-bit version, 
which has always been the definitive version of the product.

Versions

I began writing GreenPrint for my own use in June, 1996, out of frustration 
with the lengthy printouts of source code and documentation that Windows 
programming demands. Since then I have worked to add features and make 



it of wider use.

The present version of GreenPrint is 1.1 (December 1996).

GreenPrint is not freeware, but shareware. The registration fee is $15. (Follow
this link for details on how to register). The benefits of registration include
- no more nag screens
- free updates as GreenPrint evolves
- the right to have your suggestions and bug reports taken seriously
- the satisfaction of supporting the shareware concept

Future developments

Future developments planned for GreenPrint include 
- syntax highlighting in a variety of languages including C/C++, Java and Perl
- user-defined indexing, allowing a user to define a list of words or symbols in
a file to be printed and have GreenPrint automatically generate and print an 
index -- an especially useful feature when printing long files of 
documentation.
- booklet printing
Suggestions from registered users are welcome.

For the latest information and the most recent version of the program, please
visit the GreenPrint homepage at
http://www-personal.usyd.edu/au/~rjohnson/winapps/winapps.shtml





What this program is for
GreenPrint is a shareware utility designed to print source code and text 
files, saving paper and time by enabling printing multiple virtual pages to 
each physical page and allowing control over the number of lines and 
columns per page, margins and other formatting variables.

Its functionality is similar to that of mpage, with the important advantages 
of a more approachable Windows interface, and full functionality on any 
printer supported by Windows, rather than merely expensive PostScript 
lasers.

It is intended primarily for programmers, trouble-shooters and users 
intending to print out extensive documentation for shareware products.

The Print from clipboard function offers a fast way to print text from most 
Windows applications. Sources might include help files for other programs 
(including reference material such as that provided with the Windows SDK), 
and even documents in word processors.

GreenPrint offers a high degree of control over margins, numbers of lines 
and columns per virtual page and other aspects of the appearance of the 
printed text. Although originally intended to save paper by printing long files 
of source code at reduced font size, other uses could include enlarging 
output for users with poor eyesight.

Both Windows 95 and Windows 3.1 versions can be run from a server on a 
Windows network. Preferences will be saved on each client machine.

Note: Text in this help file that appears in red refers only to the 
Windows 95 version of GreenPrint (GreenPrint32).



Common Problems

Problems with particular printers

GreenPrint's default options cause it to print very close to the edges of the 
page. This is normally appropriate, but may cause printing past the edge of 
the paper on some printers.

Solutions: 
1. Check that the paper is correctly aligned in the printer's input bin.
2. If necessary, change the print options from within GreenPrint to make the 
margins narrower (go into the Advanced Print Options dialog box). Save the 
new options to make them your default, so you won't run into the same 
problem again.

GreenPrint prints garbage

Solutions:
1. Are you sure that the file you're trying to print is a text file? If you try to 
print a file in another format, such as a bitmap (.bmp) or other graphic 
(e.g. .gif) or a binary file such as an .exe or .dll, GreenPrint will do its best, 
but you won't learn much from its output. As a rule, if you can't edit it the file
with a text editor like Textpad or Notepad, you can't use GreenPrint to print 
it. Open your file with a text editor and check.
Note that some file formats fall between the two extremes of binary files and
plain text files. HTML files and RTF files are good examples. They contain 
embedded codes, which means that what GreenPrint prints may not be what 
you expect, but will be an accurate representation of the file. Of course, if 
you're working with raw HTML or RTF, this may be just what you want.
2. O.K., it is a text file. Is your printer correctly connected? Check the 
connections and try resetting the printer. If GreenPrint still doesn't work, try 
printing from Notepad and see if it does any better.
3. If you've been through step 2 and GreenPrint still doesn't work, you may 
have found a bug... If so, please let me know. See below.

GreenPrint can't find its help file

This problem results from an incomplete installation of GreenPrint.

Solutions:
GreenPrint32
1. If possible, rerun the GreenPrint installer.



2. If you can't do this, adding the correct registry entries manually is a tricky 
business, so it's easiest to add the directory where the GreenPrint files are 
located to the path by modifying your autoexec.bat file and rebooting. 
(Note that this isn't the method of choice for storing system information 
about .exe and help file locations under Windows 95.)
GreenPrint16
Add the directory where GreenPrint files are located to the path by modifying
your autoexec.bat file and reboot.

If all else fails...

Bug reports are welcome from registered users. If you have come across 
another problem with GreenPrint, please let me know. I'll be grateful and I'll 
try to fix it as soon as I can.
E-mail me at: rjohnson@extro.ucc.su.oz.au
If possible, send any files GreenPrint had trouble with as an attachment.

Rod Johnson, October 25, 1996



GreenPrint Order Form
1.2

Post to:

Rod Johnson
P.O. Box 41
Londonderry NSW 2753
AUSTRALIA

Name                                                                                                                                                    

E-mail                                                                                                                                                   

Street                                                                                                                                                    

Town/City                                                                                                                                             

Postcode/Zip                                                                                                                                      

Country                                                                                                                                                

Circle the product you wish to receive: 
        
GreenPrint32 (Windows 95/NT) GreenPrint16 (Windows 3.1)Both (no 

extra charge)

How did you find out about GreenPrint?

                                                                                                                                                                

                                                                                                                                                                

Comments/Suggestions about GreenPrint

                                                                                                                                                                

                                                                                                                                                                

                                                                                                                                                                



Payment
Cheque, money order or cash preferred.

Circle appropriate amount. To receive update via e-mail To receive 
floppy disk

U.S. $15 $20

U.K. £10 £12

Canada $C20 $C25

Australia $A15 $A20

Other countries

Money order in $A $A15 $A20
Cheque in home currency $U.S.18*

$U.S.22*

File server registration (> 3 clients): $U.S.15 + $U.S.8 x number of 
client machines

*Convert to your currency at the prevailing exchange rate at the time of your order.



GreenPrint shareware notice
GreenPrint © Rod Johnson, 1996.
All rights reserved.

Thank you for using GreenPrint! You are welcome to evaluate GreenPrint 
for 30 days after installing it on your computer. After that period, if you wish 
to continue using it, you must register, by filling in the order form. Failure to 
do so is a violation of copyright and the principles of shareware.

Registered users are entitled to free updates for the life of the product, and 
will benefit from any new functionality which may not be included in 
evaluation copies of the software.

You may distribute evaluation (but not registered) copies of the software, but
must not charge for them (except for any media).

Disclaimer

THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND 
WITHOUT WARRANTIES AS TO PERFORMANCE OR MERCHANTABILITY OR ANY 
OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED. SPECIFICALLY, NO 
WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED. THE 
AUTHOR WILL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY A LICENSEE 
AS A RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE.

Remember: Supporting the shareware concept benefits users as well 
as programmers!




